µTimer 0.3 released!

Here is a new release of µTimer, it is now version 0.3.

This version introduces new features and also lots of code improvements.

Change log between 0.3 and 0.2.1

  • Added the stopwatch feature!
    • utimer --stopwatch
  • Now you can pause and resume the timer/stopwatch/countdown using the Spacebar
  • Added --enable-debug=[no/minimal/yes] option to configure
  • Now completely rely on GTimers for calculating the elapsed time
  • Added testing units (can be run when bulding utimer, using: make test)
  • Lots of code cleanup
  • Dropped the stability for releases (stable/unstable) as they weren't very meaningful.

Download now!

 

Comments: 9

Leave a reply »

 
 
 

Since theres no other way to contact you I'm making a post here.

WordPress converts double hyphen to dash automatically:

* utimer –stopwatch

But I'm guessing it should be:

* utimer --stopwatch

:)

http://www.linuxscrew.com/2007/09/23/disable-double-hyphen-to-dash-wordpress-replacements/

Another usefull tip for a Linuxuser/coder using WP:

http://bavotasan.com/tips/removing-the-smart-quotes-from-your-wordpress-blog/

 
 

lol, forgot that the double hyphen doesnt works in comments either.

 
 

Thank you very much for those tips, the only thing is that any upgrade would overwrite this changes...

 
 

Hund, I found the wp-typography plugin which seems to have fixed those issues!
:)

 
 

You can contact at http://www.codealpha.net/contact/

WordPress is very annoying. I dislike when it replaces quotes. I don't use it.. but when reading blogs I notice.

 
 

I am glad I found your utimer, I was lookin fr somthing simple to minutize my work. The only thing I found annoying is that you need to have very recent version of glib and intltool. It is a pity one who have a system that is just a bit old, won't be able to compile such a simple tool.

 
 

Hey Regis, Thanks you for your comment, I think the source code itself should be compatible with earlier versions, but I haven't tried. I will to look at this issue and see if I can lower the requirements for glib and intltool for the next release.

 
 

Hi. On my gentoo, I had to upgrade my glib to >=2.18.2 version and intltool to >=0.40.5. Those versions are not that recent I guess, but recent enough to have me updating my libs. I guess those restrictions could indeed be lowered in the configure script. Anyway, very useful tool to me, thanks you.

 
 

Regis, please try the new version 0.4 in which I lowered the requirements.

 
 

Leave a Reply

 
  (will not be published)
 
 
 
 

 
© 2014 µTimer